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5Drawing Environment
This chapter presents information about Informed Designer’s drawing environment. You’ll lea
about the drawing window and its visual attributes, as well as the various drawing aids includ
rulers, the grid, guide lines, and the view scale.

The Drawing Window
You use the drawing window to create and edit the template of a form. When you open or cre
form template, a drawing window appears showing the template of the form.

The Drawing Window

Specs palette

Cell paletteCommand palettePage controlsInformation box

Grid lines

Guide lines RulersTool palette

Background

Print margins

Drawing area
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The elements of the Informed Designer drawing environment are briefly described below. For
information on these topics, please consult the indicated sections of this manual.

Drawing Environment Elements
Element Name Description

Drawing area

Rulers

Ruler crosshairs

Zero point marker

Grid lines

Guide lines

Page break

Print margins

Page controls

Tool palette

Specs palette

Command palette

Cell palette

The drawing area is where you draw your template. Use the Drawing 
Setup command to change the size and options of the drawing area. S
“Drawing Setup” in Chapter 3.

The rulers help you measure and position objects accurately on your te
plate.

The ruler crosshairs indicate the position of the mouse and objects relat
to the ruler.

Use the zero point marker to change the position of the ruler zero point. 
change the zero point, click and drag the zero point marker. To set the z
point to its home position, click and release the zero point marker.

Grid lines help you to accurately position and size objects on your tem-
plate.

The guide lines, like grid lines, help you position and size objects accu-
rately; use the guide lines to align objects to specific points on your tem
plate.

For forms that are larger than one page, page breaks indicate the positi
where the form crosses page boundaries. See “Page Size” in Chapter 3

Print margins show you the printable area of your template. Any object (
sections of an object) drawn outside the print margins will not print.

Use the page controls to view different pages of your template. See 
“Changing Pages” in Chapter 4.

The Tool palette contains the Pointer tool, the Tab tool, the Zoom tool, a
all drawing tools. See Chapter 6, “Drawing Tools.”

The Specs palette displays the current position and dimensions of a 
selected object on your template as well as the current position of the 
pointer. You can use the Specs palette to change the dimensions of any
object. See “Using the Specs Palette” in Chapter 8.

The Command palette provides shortcuts to many of Informed Designe
graphics commands and settings. Use the Command palette for tasks s
as aligning text, duplicating objects, locking the position of objects, and s
on. See Chapter 8.

The Cell palette provides shortcuts to many of Informed Designer’s dat
intelligence commands. See “Using the Cell Palette” in Chapter 1 of yo
Informed Designer Forms Automation manual.
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Faster scrolling

If you are running Informed Designer or Informed Filler on a Mac OS compatible computer, y
can further increase the scrolling speed of forms in Informed Designer by taking advantage o
available memory.

The amount of memory required for fast scrolling depends on the dimensions of your templa
the monitor setting of your computer. The larger the form and the more grays or colors your m
tor is displaying, the more memory you will need. You can, however, minimize the amount of m
ory required for fast scrolling by selecting a display preference. 

To select the display preference, choose Preferences... from the Edit menu. The Preferences dia
log box appears.

With the ‘General’ preference panel selected, the dialog box contains two options. The first o
‘Display form in black and white,’ will display your form in black and white. If your monitor set
ting is set to multiple grays or colors, this option will significantly reduce the required memory
your monitor is set to ‘Black & White,’ selecting this option will have no effect on the memory 
required. 

The amount of memory available to Informed Designer depends on the size of the memory pa
in which the software is running. This size can be changed to increase Informed Designer’s a
able memory. For more information, please see your Informed Designer Getting Started Guide.

For information on ‘Fractional character widths’ please see Chapter 11, “Printing Forms.”
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Using Palettes
“The Drawing Window”, earlier in this chapter, pictures the drawing window and Informed 
Designer’s various palettes. The function of each palette is explained in other sections of this
ual, and in your Informed Designer Forms Automation manual.

You can show or hide any of the Tool, Specs, Cell, or Command palettes. To do so, choose t
responding item from the Show submenu under Informed Designer’s Layout menu.

You can also hide a palette by clicking its close box. While a palette is displayed, a checkma
appears next to its name in the Show submenu.

Like drawing windows, you can move a palette to any position on the screen. Simply position
pointer in palette’s title area, click the mouse button, drag to the new position, then release th
mouse button.

Layout Preferences
To give you more design flexibility, Informed Designer allows you to change the options for va
elements of the drawing environment by using the Preferences command. For example, if yo
fer to measure in points rather than inches, you can change the ruler units from inches to po

To set your preferences, choose Preferences... from the Edit menu. The Preferences dialog box 
appears. Click the ‘Layout’ icon in the scrolling list on the left.

Using Palettes

Layout Preferences

Close box
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Details about the individual Layout Preferences and how to change them are discussed in th
lowing sections. Once you’ve selected your preferred settings, click ‘OK’ to dismiss the Prefe
ences dialog box.

Rulers
The rulers are a drawing aid that help you measure and align objects on your form. Use the ru
draw, position, and resize objects accurately. When visible, the rulers appear on the top and 
edges of the drawing window.

To display the rulers, choose Show Ruler from the Layout menu. Alternately, when the rulers are
showing, this command becomes Hide Ruler. Choose this command to hide the rulers.

Rulers

Note Before you can create a new guide line, the rulers must be visible. For more information ab
guide lines, see “Guide lines.”
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On the ‘Layout’ panel of the Preferences dialog box you can select from four basic units of m
surement: inches, centimeters, picas, and points. To change the ruler units, choose a unit fro
‘Ruler’ drop-down list.

The ruler zero point represents the intersection of the zero mark on each of the horizontal an
cal rulers. By default, the zero point is set to the top left corner of the paper. You can change
zero point to align it to any position on the drawing area.

To change the zero point, click and drag the zero point marker—the small box at the upper-le
ner of the drawing window—then release the pointer at the new position.

If you release the mouse button in the content area of the drawing window, you’ll change the
point on each ruler. If you release the mouse in the content area of either ruler, the zero poin
changes for that ruler only.

If you want to reset the zero point to its default setting, click the zero point marker once.
 
To lock the zero point, select the ‘Lock zero point’ checkbox on the Layout panel of the Prefer
dialog box. Locking the zero point prevents you from changing it accidentally. When the zero 
is locked, the short gray lines on the zero point marker disappear.

Ruler crosshairs are visual aids that help you position the mouse and objects relative to part
points on the ruler. They appear as light gray lines on each ruler.

Click here

Release here New zero point

Drag

Ruler crosshairs
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With the ruler crosshairs, you can easily position objects on the drawing area. For example, 
want to position the mouse one inch down and to the right of the ruler zero point, simply drag
mouse until the ruler crosshairs are over the one inch marks on both rulers.

The ruler crosshairs appear whenever the pointer is positioned over the drawing area or whe
you draw, drag, or resize an object. When you move the pointer, a single crosshair on each r
shows the pointer’s current horizontal and vertical position. When you draw, drag, or resize a
object, the ruler crosshairs indicate the position of the object’s edges.

If the grid is turned on, the ruler crosshairs will also snap to the grid. Ruler crosshairs are the
an accurate indication of where drawing will start while positioning the pointer.

The Grid
The grid consists of imaginary lines that run vertically and horizontally across the drawing are
form. Use the grid as an aid to position and size objects on your form.

To display the grid, choose Grid from the Show submenu under Layout. When the grid is visible
checkmark is displayed next to the Grid command. Choose Grid again to turn the grid display off. 
Grid lines are always drawn according to the options you select on the Layout panel of the P
ences dialog box. For more information about changing the appearance of the grid lines, see
options” later in this chapter.

The Grid
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If you’re using a color monitor, grid lines will appear in light blue.

With the grid, you can align objects in one of two ways: visually or by using the Snap To Grid
ture. When used visually, you position and size objects by eye so that their boundaries lie alo
grid lines.

Using Snap To Grid

When drawing, dragging, or resizing, you can have Informed Designer automatically align—o
‘snap’—objects to the grid. You do this by choosing Snap To Grid from the Layout menu. While the 
Snap To Grid feature is on, a checkmark is displayed beside the menu item to indicate that t
ture is active. To turn the snapping feature off, choose Snap To Grid again.

With the Snap To Grid feature turned on, all objects that you manipulate (by drawing, draggin
resizing) will automatically align to the grid. When you draw or resize an object, its edges wil
constrained to lie on the nearest grid lines, whichever are active. When you drag an object, i
upper-left corner will be constrained to lie along the nearest grid lines.

When turned on, the Snap To Grid feature works regardless of whether the grid lines are vis
not.
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Grid Options

With the Preferences command, you control the spacing of the grid lines on your form. Inform
Designer gives you the ability to customize the grid for each form template you design.

To set the grid options, choose Preferences... from the Edit menu. When the Preferences dialog
box appears, click the ‘Layout’ icon in the scrolling list to display the grid options.

Grid separation—the distance between each grid line—can be specified in divisions per unit 
(inches, centimeters, picas, or points) or unit separation. Select the desired method by choo
option from the ‘Horizontal grid’ and ‘Vertical grid’ drop-down lists. The unit of measurement d
played in the grid drop-down lists (as in divisions/in, divisions/cm, and so on) is determined b
which unit of measurement you’ve chosen in the ‘Ruler’ drop-down list (see “Ruler Options”).

Regardless of how you measure grid separation, you can control the exact spacing of the gr
by typing a value in the appropriate text box. If you type ‘10’ into the ‘Horizontal grid’ text box
with the grid separation set to ‘divisions /in,’ the vertical grid lines will be spaced at ten lines p
inch. If you type ‘.125’ into the ‘Horizontal grid’ text box, with the grid separation set to ‘inche
the vertical grid lines will be spaced 1/8 of an inch apart.

Use the ‘Draw every’ text boxes to control the visual density of grid lines on your form templa
When you enter values into these text boxes, you specify how many grid lines are drawn acr
your form. For example, if the horizontal grid lines are spaced at five divisions per inch, and y
type ‘5’ into the ‘Draw every’ text box, then one vertical line will be drawn for every five vertica
lines on the grid (that is, one grid line every inch). 

Guide Lines
Guide lines run vertically and horizontally along the drawing area of your form. Like the grid, 
use guide lines as an alignment aid. However, they differ from grid lines because you create 
adjust each guide line independently—one line at a time. With the help of the rulers you can p
guide line at any position on the drawing area, allowing you to align objects to a specific pos
on your form.

To display the guide lines, choose Guides from the Show submenu under Layout. When you choo
Guides, a checkmark appears beside the Guides command to indicate that the feature is act
you’re using a color monitor, guide lines will appear in blue. To hide the guides, choose Guides 
again. 

Guide Lines
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Before creating a guide line, make sure that the rulers are visible. Then, click in the content a
either ruler and drag the mouse onto the drawing area of your form. Release the mouse butto
the new guide line is aligned at the desired position.

To remove a guide line, click and drag it back into the content area of the ruler, or drag it com
pletely off the top or left edge of the drawing window if the rulers aren’t displayed.

The Snap To Guides Feature

When drawing, dragging, or resizing an object, you can have Informed Designer automatical
snap the object to the guide lines on your form. You do this by choosing Snap To Guides from the 
Layout menu.

With the Snap To Guides feature on, any object that you manipulate (by drawing, dragging, o
resizing) will automatically align to the nearest guide line, provided that the object falls within
pixels, the guide line’s ‘sensitivity area.’

Note If you reduce the size of the drawing area (using the Drawing Setup command), Informed 
Designer will automatically remove any guide lines that no longer lie in the drawing area.

Click in the ruler’s
content area...

...drag... ...and release.

Click and drag the object to
the appropriate guide line.
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While the Snap To Guides feature is on, a check appears beside the corresponding menu ite
turn the snapping feature off, choose Snap To Guides again. The menu item will be unchecked, 
allowing you to manipulate objects on a pixel by pixel basis. The Snap To Guides feature wo
regardless of whether or not the guide lines are displayed.

If you want to lock the guide lines, select the ‘Lock guides’ option on the Preferences dialog b
This prevents you from accidentally moving the guide lines while you’re editing your form.

View Scale
While editing your form, you can change the view scale of the drawing window. Changing the
scale allows you to view more or less of the drawing area in the drawing window. By reducing
view scale you can see and work with a larger area of the form. By enlarging the view scale,
can work with your form close up for greater precision.

Changing the View Scale

You change the view scale of the drawing window by using the Zoom tool or by choosing a v
scale from the ‘View’ drop-down list. Informed Designer allows you to view a form at 25, 50, 1
200, 400, 800, and 1600 percent of its actual size.

When you change the view scale, the elements of your form are enlarged or reduced accord
However, Informed Designer’s drawing aids such as the rulers, grid lines, guide lines and ob
handles always remain the same size.

View Scale
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The current view scale of the drawing window is displayed in the ‘View’ drop-down list in the 
lower-left corner of the drawing window.

To change the view scale using the ‘View’ drop-down list, simply click the drop-down list and 
choose a view scale from the options listed.

The Zoom tool (the ‘magnifying glass’) enlarges or reduces the view scale of your form. To us
Zoom tool, first select it from the tool palette and move the pointer to the position of interest o
drawing window. Click the mouse button once to bring your form to the next larger scale (from
to 200 percent, for example). The ‘View’ drop-down list in lower-left corner of the drawing wind
will change to indicate the current view scale.

When enlarging a drawing with the Zoom tool, the area on the drawing that lies under the Zo
tool will be centered in the drawing window when you click the mouse button.

Similarly, you can reduce the current view scale of the drawing window by clicking the Zoom
in the drawing window while holding down the Alt (Windows) or Option (Mac OS) key.

To change the view scale of the drawing window to its actual size, simply double-click the Zo
tool on the tool palette. This changes the drawing window’s view to 100% (actual size).

Drawing Accuracy
Drawing accuracy refers to the level of precision with which you can size and position object
your form. The higher the drawing accuracy, the more control you have over an object’s exac
and position.

Drawing accuracy is measured in dots per inch (dpi). The number of dots per inch correspon
directly to how accurately you can position or size an object within a one inch distance. For e
ple, if the drawing accuracy were 72 dpi, the smallest distance that you could move an object 
be 1/72nd of an inch.

Note You can also set the view scale to 100% by pressing the Control-1 (Windows) or Comman
(Mac OS) keystroke combination.

Drawing Accuracy

‘View’ drop-down list

72 dots



 

5-14 Drawing Environment

 .
 .

 .

 

en 72 
here-
 one 

ew 
w 

racy 
e 
 a time 
raw-
 an 

n 
er to 

00%.

  

 form, 
t when 

tical 
dis-

nother 
iew 

  

-
will 
e 
.
The drawing accuracy of your computer screen—sometimes called screen resolution—is oft
dpi. This means that in any direction, there are 72 dots, or pixels, from one inch to the next. T
fore, when the view scale of the drawing window is 100% (actual size), moving an object from
pixel to the next will move the object a distance of 1/72nd of an inch. (You can change the vi
scale of the drawing window using either the Zoom tool or the ‘View’ drop-down list. See “Vie
Scale” for more information.)

If you change the view scale of the drawing window, you effectively change the drawing accu
as well. Each time you enlarge the view scale, the drawing accuracy doubles. This is becaus
although everything becomes twice as large, you can still move an object one screen pixel at
(which is now half the distance). If you enlarge the view scale from actual size to 200%, the d
ing accuracy changes from 72 to 144 dpi. The smallest distance that you can move or resize
object changes from 1/72nd to 1/144th of an inch.

Informed Designer allows a maximum drawing accuracy of 1152 dpi. This means that you ca
change the position or size of an object by a distance as small as 1/1152nd of an inch. In ord
obtain this level of precision, you have to change the view scale of the drawing window to 16

Limiting the Drawing Accuracy

Even though precise drawing accuracy is often necessary to position objects exactly on your
you should be aware of possible—and often unexpected—alignment problems that can resul
you manipulate objects at different view scales.

Suppose that you enlarge the view scale of the drawing window to 400% and draw a thin ver
line three pixels to the right of one inch. Since the drawing accuracy is 288 dpi at 400%, the 
tance of three screen pixels is 3/288ths of an inch.

After drawing the line, let’s say that you change the view scale back to actual size and draw a
line over top of the first one. Since the maximum drawing accuracy is only 72 dpi when the v

Note You can select a maximum drawing accuracy by choosing a setting from the ‘Drawing accu
racy’ drop-down list on the Layout panel of the Preferences dialog box. Informed Designer 
limit the drawing accuracy to this setting, even if you change the view to a larger scale. Se
“Limiting the Drawing Accuracy” below.

288 dots

2 dots past one inch
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scale is 100%, you wouldn’t be able to position the second line as accurately as the first. Eve
though the two lines would appear to be at the same position, their exact locations would be
ent. This would become apparent if you enlarged the view scale, or if you printed the form on
high resolution output device.

To avoid this problem, Informed Designer allows you to limit the drawing accuracy. You can s
maximum drawing accuracy by choosing a value from the ‘Drawing accuracy’ drop-down list 
the ‘Layout’ panel of the Preferences dialog box.

When you limit the drawing accuracy, Informed Designer restricts the placement of objects to
corresponding resolution. For example, if you choose a maximum drawing accuracy of 72 dp
Informed Designer won’t allow you to move an object less than 1/72nd of an inch, even if you
enlarge the view scale to 200% or more.

By restricting the drawing accuracy to 72 dpi, you could avoid the alignment problem discuss
above. When you’d try to draw the first line at three pixels to the right of one inch, Informed 
Designer would force the position of the line to 1 and 1/72nd of an inch—an even multiple of
drawing accuracy. At the 100% view scale, you could then draw the second line precisely on 
the first.
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Paper and Background Color
You can make your forms more visually appealing by changing the color of the paper and ba
ground that appear on the screen.

The controls for changing the paper and background color are found on the ‘Layout’ panel of
Preferences dialog box. Choose Preferences... from the Edit menu. When the Preferences dialo
box appears, click the ‘Layout’ icon in the scrolling list.

To change the paper and background color for your form, click the ‘Paper’ or ‘Background’ dr
down lists and select a color from the color palette displayed. Click ‘OK’ to save the changes
cancel the changes and dismiss the Preferences dialog box, click ‘Cancel.’

Paper and Background Color

background

paper
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